UKSaabs

THE site for UK Saab people!
It is currently Tue May 21, 2019 5:10 pm

All times are UTC



Forum rules


When you put a new thread up in the Workshop please put your car's year and model in the thread title, along with just a brief indicator of the problem.

Car Year - Car Model: Brief description of issue. EXAMPLE- 1999 9-3. Problems starting when hot.

Please also add as much information as you can about the problem, to your post.

This will help us to help you, without having to ask basic details such as what car you have.


Threads with non-compliant titles will be moved to The Pit Lane (in which no replies can be posted, but the OP can edit the thread - upon which the thread will be released to the workshop forum)

Nb. Generic thread titles for truly generic issues that genuinely are not model or variant specific (such as "how do I change the spring in an forge wastegate actuator") are acceptable

**The first 5 posts for new users require individual moderator approval (which they will only get it if they are in line the rules of the forum). Please be patient and allow time for that to happen, and avoid duplicate postings.**



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Fri Nov 23, 2018 5:07 am 
Offline

Joined: Sat Sep 08, 2018 3:58 pm
Posts: 7
Car Model: 1999 93 SE Sport
Been running great until the other day.

Started up fine, drove a few miles. Picked up the middle boy got back in and it started up fine, then cut out with a gentle shudder and an oil light flash. Then wouldn't start at all.

Battery fine, oil checked seems fine, sparks seem fine. Suspect its a fuel to the engine issue??

Any advice appreciated.

Thanks


Top
 Profile  
 
PostPosted: Fri Nov 23, 2018 11:25 am 
Offline
UKS Addict

Joined: Sun Jan 26, 2014 9:41 am
Posts: 3115
Location: Royal Tunbridge Wells
Car Model: '03 9-5 2.3 Vector Auto Estate
Assuming a B204 engine it should not suffer from sludging, does it still turn over OK? If a B205 has it had a sump drop and replacement PCV tubing? However, when they fail due to sludging it is normally a little more dramatic/noisy. The oil light may be just due to the engine stopping.

Do you hear the fuel pump spin up for a second when you turn the key to 'Ignition' (not start), pressurising the fuel system? If not it is probably the fuel pump. There is a relay (remove the panel under the steering column) but it is normally a failed pump. Unfortunately on the OG9-3 GM put the access hatch under the rear seat offset from the pump position so you either have to drop the tank or cut a hole in the floor. I did the latter, not too difficult, there are YouTube videos on it. I used a replacement pump kit from Saabits in the existing 'plant pot' holder, no problems since.

_________________
Alan

'03 Saab 9-5 2.3t Vector Estate Auto Noob Stg 1
'01 Saab 9-3 2.0t SE Vert
'81 Triumph TR7 DHC


Top
 Profile  
 
PostPosted: Sat Jan 12, 2019 9:01 am 
Offline

Joined: Sat Sep 08, 2018 3:58 pm
Posts: 7
Car Model: 1999 93 SE Sport
So I've had the fuel pump replaced. It's kicking in when i turn the key but it wont start.

PLEASE HELP

Fuel pump replaced but it still wont start

:argh: :argh: :argh: :argh:


Top
 Profile  
 
PostPosted: Sat Jan 12, 2019 11:03 am 
Offline
UKS Addict

Joined: Sun Jan 26, 2014 9:41 am
Posts: 3115
Location: Royal Tunbridge Wells
Car Model: '03 9-5 2.3 Vector Auto Estate
Is it a B204 or a B205? The control systems are different (T5.5 or T7).

What do you mean by 'kicking in'? Is just turning over or is it firing?

Do all the dash lights come up and then check OK and go out when switched on? No CEL?

First thoughts are CPS (but normally gives hot start problems first) or DI unit (but they normally misfire under load first).

_________________
Alan

'03 Saab 9-5 2.3t Vector Estate Auto Noob Stg 1
'01 Saab 9-3 2.0t SE Vert
'81 Triumph TR7 DHC


Top
 Profile  
 
PostPosted: Sun Jan 13, 2019 4:29 pm 
Offline

Joined: Sat Sep 08, 2018 3:58 pm
Posts: 7
Car Model: 1999 93 SE Sport
Thanks Alan...I've been away,gonna spend some time with car tomorrow and I'll try to answer your questions.

Thanks again I'll be back with an update tomorrow...desperate to get this great car back on the road.

Ta


Top
 Profile  
 
PostPosted: Mon Jan 14, 2019 12:45 pm 
Offline

Joined: Sat Sep 08, 2018 3:58 pm
Posts: 7
Car Model: 1999 93 SE Sport
So the pump is intermittently running.....its turning over. At one stage it came close to running bit now nothing?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

follow UKSaabs on Twitter



UKSaabs silhouette logo images by Mark Green www.greenphotos.com
"subsilver2" slightly bodged by UKSaabs for our own use.

:: Disclaimer ::
Comments posted here are the views of their individual authors and are not necessarily shared by the owners of this Web site.
Authors assume all responsibility for comments posted here.

UKSaabs The biggest and best privately owned UK based independent Saab forum for all SAAB enthusiasts.
Whilst we encourage our users to support our advertisers the site wishes to remain independent and therefore does not endorse any particular advertiser(s)
UKSaabs is not affiliated with Saab Cars UK or Saab Automobile AB