UKSaabs

THE site for UK Saab people!
It is currently Wed May 27, 2020 8:58 am

All times are UTC





Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Am I amped or not?
PostPosted: Fri May 22, 2020 1:14 pm 
Offline

Joined: Tue May 19, 2020 1:59 pm
Posts: 6
Car Model: 2001 Convertible SE
Thank you for your helpful replies to my previous issue, I know have a follow-up which I am posting as a new topic. I have a 2002 Convertible SE, I am looking for the amp which I don't think I have. I have no sound coming from my speakers, which was one of the faults with the original unit (it would cut out more than in). I have no door speakers so just four in the car I think and in the centre tunnel to the left of the heater controls on the passenger side there is no amp. Is there anywhere else this amp would be and is there a fault I may have overlooked with the speakers? I still have sound from the indicators and all my fuses are fine. Thanks again in advance for your replies, they are really appreciated.


Top
 Profile  
 
 Post subject: Re: Am I amped or not?
PostPosted: Fri May 22, 2020 3:11 pm 
Offline
UKS Addict
User avatar

Joined: Wed Nov 22, 2006 10:32 pm
Posts: 6021
Location: Glenrothes, Fife
Car Model: 95, 99, 900, 9000, 93, Sonett
I think the location on the lower left of the dash was the only factory position for the amplifier. If your car has four speakers - two in the dash and two in the rear quarters - it probably won't have the amp fitted. Are none of the speakers working? That would suggest an issue with the head unit. We had this problem with my wife's OG93, the radio would work for the first 5 minutes of any journey, then it would cut out and not work again until the next day. Replaced her head unit with a spare one, and it's been fine since.

_________________
MY70 95 V4 Van
MY73 95 V4
MY73 Sonett 3
MY83 99GL
MY89 900i S
MY96 9000 Aero
MY02 93 2.2 TiD x2


Top
 Profile  
 
 Post subject: Re: Am I amped or not?
PostPosted: Fri May 22, 2020 3:16 pm 
Offline

Joined: Tue May 19, 2020 1:59 pm
Posts: 6
Car Model: 2001 Convertible SE
Thanks for the quick reply - definitely no amp in the centre tunnel by the heater, the new head unit I fitted still has the same issue, no sound front or back, I even refitted the old original head unit and it powered up fine, the steering wheel control for sourde worked fine but no sound from the speakers whichever head unit I try. There was intermittent sound from all the speakers for a while until a few weeks back but nothing now. :(


Top
 Profile  
 
 Post subject: Re: Am I amped or not?
PostPosted: Fri May 22, 2020 3:32 pm 
Offline
UKS Addict
User avatar

Joined: Wed Nov 22, 2006 10:32 pm
Posts: 6021
Location: Glenrothes, Fife
Car Model: 95, 99, 900, 9000, 93, Sonett
Are the speakers the originals? I had one of my rear speakers die because of a split cone. In one of our other cars, three of the speakers have no output, and the fourth makes a buzzy rasp. The wiring all checks out fine, so I've concluded the speakers need replaced, and have bought new ones. But as they are such a complete nightmare to replace, it's been on the list for three years now - the entire interior needs to come out... :argh:

_________________
MY70 95 V4 Van
MY73 95 V4
MY73 Sonett 3
MY83 99GL
MY89 900i S
MY96 9000 Aero
MY02 93 2.2 TiD x2


Top
 Profile  
 
 Post subject: Re: Am I amped or not?
PostPosted: Fri May 22, 2020 4:21 pm 
Offline
UKS Encyclopædia G-M
User avatar

Joined: Sun Aug 15, 2004 9:39 am
Posts: 41459
Location: SW Herts
Car Model: 9-5 Aero est. 9-3 Carlsson
If the car had an aftermarket headunit before you bought it, it may have been removed in a hurry and things bodged together.

_________________
.
.
.
.
Everything will be OK in the end. If it's not OK, it's not the end...


Top
 Profile  
 
 Post subject: Re: Am I amped or not?
PostPosted: Fri May 22, 2020 9:09 pm 
Offline

Joined: Tue May 19, 2020 1:59 pm
Posts: 6
Car Model: 2001 Convertible SE
It had the original unit in when I bought it and it worked intermittently, speaker-wise. Now with the new head unit it is exactly the same, what am I missing, what might have caused the speakers to not be working properly?


Top
 Profile  
 
 Post subject: Re: Am I amped or not?
PostPosted: Sat May 23, 2020 2:21 am 
Offline
Saab Nut

Joined: Mon Apr 07, 2014 5:22 am
Posts: 1194
Location: Ashford, Kent.
Car Model: 93 convertible Aero MMI
Hi. There is something about speakers in the knowledge base section.

_________________
Do you know what nemesis means?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

follow UKSaabs on Twitter



UKSaabs silhouette logo images by Mark Green www.greenphotos.com
"subsilver2" slightly bodged by UKSaabs for our own use.

:: Disclaimer ::
Comments posted here are the views of their individual authors and are not necessarily shared by the owners of this Web site.
Authors assume all responsibility for comments posted here.

UKSaabs The biggest and best privately owned UK based independent Saab forum for all SAAB enthusiasts.
Whilst we encourage our users to support our advertisers the site wishes to remain independent and therefore does not endorse any particular advertiser(s)
UKSaabs is not affiliated with Saab Cars UK or Saab Automobile AB