UKSaabs

THE site for UK Saab people!
It is currently Thu Nov 26, 2020 11:57 pm

All times are UTC



Forum rules


When you put a new thread up in the Workshop please put your car's year and model in the post subject/thread title, along with just a brief indicator of the problem.

Car Year - Car Model: Brief description of issue. EXAMPLE- 1999 9-3. Problems starting when hot.

For Tech II issues or help requests please state the following in your title ''Tech 2 help required - state issue and your location ''.


Please also add as much information as you can about the problem, to your post.

This will help us to help you, without having to ask basic details such as what car you have.


Threads with non-compliant titles will be moved to The Pit Lane (in which no replies can be posted, but the OP can edit the thread - upon which the thread will be released to the workshop forum, note compliant threads will be moved back when the mod/admin team next visit the Pit Lane. if your thread has been sat in the Pit Lane for 24hrs+ after editing, pm Tech II to request release)

Nb. Generic thread titles for truly generic issues that genuinely are not model or variant specific (such as "how do I change the spring in an forge wastegate actuator") are acceptable

**The first 5 posts for new users require individual moderator approval (which they will only get it if they are in line the rules of the forum). Please be patient and allow time for that to happen, and avoid duplicate postings.**



Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Thu Nov 12, 2020 5:26 pm 
Offline

Joined: Thu Nov 12, 2020 5:10 pm
Posts: 1
Car Models: 9-5 1.9tid vector sport
Hi guys, I’m after some needed advice. I have recently had blue smoke coming from exhaust after around 10-15 mins of driving the car, also burning smell too. Once the smoke starts if I pull over and turn car on and off the smoke goes for a while but does come back. Car drives fine and hasn’t lost any power. I have recently had cam belt and water pump done and oil and filter change. It has also just had a brand new manifold fitted as the swirl flaps failed on old one. So the car has had a fair few quid spent on her lately. I’ve been reading on the forum that it may be pcv valve, turbo seals or the piston rings. As you can imagine I’m hoping it’s not the latter two. And is just pcv valve that needs replacing. Could anybody bring a bit of light to the end of my tunnel if possible as I would love to keep the car on road. Thanks in advance guys! :wall:


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: Ahrefs [Bot] and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

follow UKSaabs on Twitter



UKSaabs silhouette logo images by Mark Green www.greenphotos.com
"subsilver2" slightly bodged by UKSaabs for our own use.

:: Disclaimer ::
Comments posted here are the views of their individual authors and are not necessarily shared by the owners of this Web site.
Authors assume all responsibility for comments posted here.

UKSaabs The biggest and best privately owned UK based independent Saab forum for all SAAB enthusiasts.
Whilst we encourage our users to support our advertisers the site wishes to remain independent and therefore does not endorse any particular advertiser(s)
UKSaabs is not affiliated with Saab Cars UK or Saab Automobile AB