UKSaabs

THE site for UK Saab people!
It is currently Tue Jul 14, 2020 2:54 am

All times are UTC



Forum rules


When you put a new thread up in the Workshop please put your car's year and model in the post subject/thread title, along with just a brief indicator of the problem.

Car Year - Car Model: Brief description of issue. EXAMPLE- 1999 9-3. Problems starting when hot.

For Tech II issues or help requests please state the following in your title ''Tech 2 help required - state issue and your location ''.


Please also add as much information as you can about the problem, to your post.

This will help us to help you, without having to ask basic details such as what car you have.


Threads with non-compliant titles will be moved to The Pit Lane (in which no replies can be posted, but the OP can edit the thread - upon which the thread will be released to the workshop forum, note compliant threads will be moved back when the mod/admin team next visit the Pit Lane. if your thread has been sat in the Pit Lane for 24hrs+ after editing, pm Tech II to request release)

Nb. Generic thread titles for truly generic issues that genuinely are not model or variant specific (such as "how do I change the spring in an forge wastegate actuator") are acceptable

**The first 5 posts for new users require individual moderator approval (which they will only get it if they are in line the rules of the forum). Please be patient and allow time for that to happen, and avoid duplicate postings.**



Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Sat Nov 30, 2019 10:06 pm 
Offline
Active user

Joined: Sun Mar 05, 2017 10:26 am
Posts: 38
Car Models: 2009 93 tid
Left car for just over a week started today and I have low power mode on dash drove it about 10 miles drives as normal :!:


Top
 Profile  
 
PostPosted: Sat Dec 07, 2019 4:35 pm 
Offline
Active user

Joined: Sun Mar 05, 2017 10:26 am
Posts: 38
Car Models: 2009 93 tid
Went on decent run for over a hour today kept in 4th gear 3,000 revs as much as I could it’s definitely not lost any power low power warning is still on would a clogged Egr be a fair guess


Top
 Profile  
 
PostPosted: Wed Dec 18, 2019 4:05 pm 
Offline
Full Pressure Turbo
User avatar

Joined: Sat Aug 09, 2014 5:06 pm
Posts: 684
Location: Sunny Manchester
Car Models: 9-3 TiD auto
You need the codes reading. Once you have them post here as somebody's probably already had/ fixed similar.

_________________
Noob'd 2.0t 9-5 estate 420Nm & 275bhp RIP :(
9-3 TiD auto estate


Top
 Profile  
 
PostPosted: Mon Dec 23, 2019 10:13 am 
Offline
Active user

Joined: Sun Mar 05, 2017 10:26 am
Posts: 38
Car Models: 2009 93 tid
The codes are CIm u2100 op CIM was missing on p bus
Tcs u2103 oo tcs/esp was missing on bus
EDC p065 04 a/c relay circuit open
EDC p0650 04check engine lamp circuit , open
I had water leak in passenger footwell about month ago I’m wondering if that’s anything to do with it going to strip out passenger footwell carpets insulation on Christmas Eve as I’m off


Top
 Profile  
 
PostPosted: Tue Dec 31, 2019 10:40 pm 
Offline
Active user

Joined: Sun Mar 05, 2017 10:26 am
Posts: 38
Car Models: 2009 93 tid
This is definitely a bad connector somewhere I have no eml light on dash now , I have cleaned and checked all contacts around engine and in N/s footwell any suggestions, over last few days I have cleaned Egr valve throttle body inlet pressure sensor etc


Top
 Profile  
 
PostPosted: Wed Jan 01, 2020 11:58 am 
Offline
UKS Addict

Joined: Tue Feb 10, 2015 8:13 pm
Posts: 2530
Location: Peterborough UK
Car Models: 9-5 Aero 2001,1.9TID x 2
If you check the fault codes in the WIS (download Tech2 section on saabcentral) they indicate a likely problem with the connectors at the EDC16 ECU which resides at the front
of the driver side wheel arch.


Top
 Profile  
 
PostPosted: Wed Jan 01, 2020 11:04 pm 
Offline
Active user

Joined: Sun Mar 05, 2017 10:26 am
Posts: 38
Car Models: 2009 93 tid
Thanks that’s the next place to check


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: Ahrefs [Bot], Google [Bot] and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

follow UKSaabs on Twitter



UKSaabs silhouette logo images by Mark Green www.greenphotos.com
"subsilver2" slightly bodged by UKSaabs for our own use.

:: Disclaimer ::
Comments posted here are the views of their individual authors and are not necessarily shared by the owners of this Web site.
Authors assume all responsibility for comments posted here.

UKSaabs The biggest and best privately owned UK based independent Saab forum for all SAAB enthusiasts.
Whilst we encourage our users to support our advertisers the site wishes to remain independent and therefore does not endorse any particular advertiser(s)
UKSaabs is not affiliated with Saab Cars UK or Saab Automobile AB