UKSaabs

THE site for UK Saab people!
It is currently Fri Jul 03, 2020 11:00 pm

All times are UTC



Forum rules


When you put a new thread up in the Workshop please put your car's year and model in the post subject/thread title, along with just a brief indicator of the problem.

Car Year - Car Model: Brief description of issue. EXAMPLE- 1999 9-3. Problems starting when hot.

For Tech II issues or help requests please state the following in your title ''Tech 2 help required - state issue and your location ''.


Please also add as much information as you can about the problem, to your post.

This will help us to help you, without having to ask basic details such as what car you have.


Threads with non-compliant titles will be moved to The Pit Lane (in which no replies can be posted, but the OP can edit the thread - upon which the thread will be released to the workshop forum, note compliant threads will be moved back when the mod/admin team next visit the Pit Lane. if your thread has been sat in the Pit Lane for 24hrs+ after editing, pm Tech II to request release)

Nb. Generic thread titles for truly generic issues that genuinely are not model or variant specific (such as "how do I change the spring in an forge wastegate actuator") are acceptable

**The first 5 posts for new users require individual moderator approval (which they will only get it if they are in line the rules of the forum). Please be patient and allow time for that to happen, and avoid duplicate postings.**



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Nov 16, 2019 9:59 pm 
Offline
Active user

Joined: Sat Oct 08, 2016 7:08 pm
Posts: 34
Car Models: 9-3
Hi all,
I did an oil change on my 2004 9-3 Aero (210bhp) today, and while I was under there, I noticed not one but two separate oil leaks. The first seems to be coming from the pulley side crankshaft oil seal. I was aware of this leak previously but it seems to be getting worse. I think I'm going to have to bite the bullet and replace the seal. After a bit of googling it looks like this is fairly doable, just a matter of removing the arch liner and engine mount, then dropping the engine a bit, removing the pulley, and replacing the seal. I have two questions though.
1. Do I need to remove the timing case for this, and if so then I assume I'll need a new gasket?
2. Can I reuse the pulley bolt or do I need to replace it (And what should the bolt be torqued to?)

The second leak seems to dripping down out of the bell housing. It looks like engine oil, but I wanted to check the gearbox oil level. After some googling it looks like the six speed gearbox doesn't have a level bung, is that correct? People seem to be saying that the gearbox oil is a distinctive red colour, but is that likely to still be true after 110k miles? Finally (sorry I've so many questions :oops: ), is there anything to be aware of when replacing the flywheel side crank seal or is it fairly straightforward?


Top
 Profile  
 
PostPosted: Sun Jan 05, 2020 4:59 pm 
Offline
Active user

Joined: Sat Oct 08, 2016 7:08 pm
Posts: 34
Car Models: 9-3
So, an update in case anyone is interested!
I went ahead and replaced the timing chain side crank seal. It definitely seemed to be leaking, the was oil sprayed all around it. I removed the wheel arch liner for access, but then to get at the aux belt tensioner to remove the belt I had to remove the air box and engine mount. Jacking the engine up allowed me to remove the aux belt, and dropping it down allowed me on to the pulley bolt with socket. Very straightforward job, I removed the pulley, then the old seal, replaced the seal, and then the pulley. I reused the old bolt and simply tightened it up with an impact wrench as I didn't have a torque figure.
I noticed that the flange on the pulley has a small groove worn into it by the seal, so ideally I'd have replaced it too, but I think a new seal seems to have solved the problem for now.

I'm in two minds about the gearbox side oil leak, I think now it might be running down the back of the engine and onto the bottom of the bell housing. Will have to investigate further.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: Ahrefs [Bot] and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

follow UKSaabs on Twitter



UKSaabs silhouette logo images by Mark Green www.greenphotos.com
"subsilver2" slightly bodged by UKSaabs for our own use.

:: Disclaimer ::
Comments posted here are the views of their individual authors and are not necessarily shared by the owners of this Web site.
Authors assume all responsibility for comments posted here.

UKSaabs The biggest and best privately owned UK based independent Saab forum for all SAAB enthusiasts.
Whilst we encourage our users to support our advertisers the site wishes to remain independent and therefore does not endorse any particular advertiser(s)
UKSaabs is not affiliated with Saab Cars UK or Saab Automobile AB