UKSaabs

THE site for UK Saab people!
It is currently Thu Oct 24, 2019 5:29 am

All times are UTC



Forum rules


When you put a new thread up in the Workshop please put your car's year and model in the thread title, along with just a brief indicator of the problem.

Car Year - Car Model: Brief description of issue. EXAMPLE- 1999 9-3. Problems starting when hot.

Please also add as much information as you can about the problem, to your post.

This will help us to help you, without having to ask basic details such as what car you have.


Threads with non-compliant titles will be moved to The Pit Lane (in which no replies can be posted, but the OP can edit the thread - upon which the thread will be released to the workshop forum)

Nb. Generic thread titles for truly generic issues that genuinely are not model or variant specific (such as "how do I change the spring in an forge wastegate actuator") are acceptable

**The first 5 posts for new users require individual moderator approval (which they will only get it if they are in line the rules of the forum). Please be patient and allow time for that to happen, and avoid duplicate postings.**



Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Tue Sep 10, 2019 9:44 am 
Offline
Active user

Joined: Fri Sep 18, 2015 7:42 am
Posts: 64
Location: Reading
Car Model: 9-5 Vector
Hi all

On the way to work this morning about 5 minutes after i set off, i pulled up to some traffic lights, and as it was idling i felt the engine splutter and almost cut out. It recovered to regular idle but then a fair amount of white smoke followed out the exhaust.

On pulling away the smoke cleared but then when changing gear and accelerating a huge cloud of whiteish smoke filled my rear view mirror. I tired this a few times with the same result. If i dont accelerate hard and then change gear i only get the smallest amount of blue smoke.

On arriving at work i left it running, opened the bonnet and it stinks of burning oil, but no obvious leaks in the engine bay. When i revved it lightly, about 1200 rpm, igot some fairly heavy blue smoke.

Im suspecting turbo seals have let go, but it concerned me that it happened so suddenly when i was at idle, also i have had no previous smoke at all in the last 4 years of ownership.

Any help is appreciated. Cheers

_________________
"He looks like a horse in a man costume"


Top
 Profile  
 
PostPosted: Tue Sep 10, 2019 10:03 am 
Offline
UKSaabs Trader
User avatar

Joined: Wed May 12, 2004 9:53 pm
Posts: 17004
Location: Devon
When the seals went on my 9000 Aero it happened suddenly. No smoke at all one minute, the next I was driving along and noticed a large plume of smoke behind the car. I can't say whether it happened while I was driving along or idling but up to that point there had never been any smoke at all. Of course they're very different turbos and the Aero's TD04 isn't known for dying like your GT17 but that was my experience anyway.

_________________
www.SAABits.com - helping to keep Saabs on the road
Discount for UKS members: enter code UKS2019


Top
 Profile  
 
PostPosted: Tue Sep 10, 2019 11:37 am 
Offline
UKS Encyclopædia G-M
User avatar

Joined: Sun Aug 15, 2004 9:39 am
Posts: 40719
Location: SW Herts
Car Model: 9-5 Aero est. 9-3 Carlsson
Had a similar symptom when the turbo on my 9-5 failed last year. You will need to take off one end pipe from the turbo and see if the shaft is wobbly. It probably is...

_________________
.
.
.
.
Everything will be OK in the end. If it's not OK, it's not the end...


Top
 Profile  
 
PostPosted: Wed Sep 11, 2019 9:55 am 
Offline
Active user

Joined: Fri Sep 18, 2015 7:42 am
Posts: 64
Location: Reading
Car Model: 9-5 Vector
Ok so it probably is my turbo.

I went out on my lunch break to check the oil, and it had dropped below minimum. I topped it up as i had oil in the car. I checked my PCV valve at the back of the engine (it was still good) and started the car. I've never seen so much smoke in my life. It was mostly white with a blue tinge, and filled my entire work car park (outside).

I got the car recovered as i didn't fancy driving it back lol.

I'm going to do a compression test this weekend before i pull any turbo pipework just to make sure i haven't blown a piston ring. Providing the compression test results are ok, is there anything else people recommend me to check before I spend the money changing my turbo? (Which i will check for wobbly shaft and leaky seals etc).

Cheers

_________________
"He looks like a horse in a man costume"


Top
 Profile  
 
PostPosted: Wed Sep 11, 2019 10:09 am 
Offline
UKS Addict
User avatar

Joined: Sat Jun 02, 2012 9:25 pm
Posts: 4991
Location: Ingleby barwick, cleveland
Car Model: 2000 9-3 viggen convertible.
Check for any oil in this tube.

Image

_________________
2000 9-3 2.3 viggen convertible.
NoobTune Stage 3, with Wossners.
http://miikka.org/saabcode/


Top
 Profile  
 
PostPosted: Wed Sep 11, 2019 10:40 am 
Offline
Active user

Joined: Sat Jan 12, 2013 9:02 pm
Posts: 158
Location: Oxfordshire
Car Model: 9-5 Vector 2.0t;Merc Benz;
KoniTec wrote:
Ok so it probably is my turbo.

I went out on my lunch break to check the oil, and it had dropped below minimum. I topped it up as i had oil in the car. I checked my PCV valve at the back of the engine (it was still good) and started the car. I've never seen so much smoke in my life. It was mostly white with a blue tinge, and filled my entire work car park (outside).

I got the car recovered as i didn't fancy driving it back lol.

I'm going to do a compression test this weekend before i pull any turbo pipework just to make sure i haven't blown a piston ring. Providing the compression test results are ok, is there anything else people recommend me to check before I spend the money changing my turbo? (Which i will check for wobbly shaft and leaky seals etc).

Cheers

I had that on my 9-5 2.3 and it was the turbo. Had to replace it. :(


Top
 Profile  
 
PostPosted: Thu Sep 12, 2019 7:17 pm 
Offline
Active user

Joined: Fri Sep 18, 2015 7:42 am
Posts: 64
Location: Reading
Car Model: 9-5 Vector
So i did a cold compression test. Results were:

180, 175, 165, 180 psi. This was done while the engine was cold. 2 and 3 were a little down but seem within spec.

Plugs were all covered in oil. Took the cobra pipe off and sure enough the compressor wheel was wobbling all over the place.

Looks like il be busy over the weekend then lol.

_________________
"He looks like a horse in a man costume"


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

follow UKSaabs on Twitter



UKSaabs silhouette logo images by Mark Green www.greenphotos.com
"subsilver2" slightly bodged by UKSaabs for our own use.

:: Disclaimer ::
Comments posted here are the views of their individual authors and are not necessarily shared by the owners of this Web site.
Authors assume all responsibility for comments posted here.

UKSaabs The biggest and best privately owned UK based independent Saab forum for all SAAB enthusiasts.
Whilst we encourage our users to support our advertisers the site wishes to remain independent and therefore does not endorse any particular advertiser(s)
UKSaabs is not affiliated with Saab Cars UK or Saab Automobile AB